Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
Programming
 EXP Systems Forum : PDF reDirect : Programming
Topic: PRINTER NOT FOUND after re-installing Windows Post Reply Post New Topic
Author Message
steve
Newbie
Newbie
Avatar

Joined: 18 Mar 08
Location: United States
Posts: 5
Quote steve Replybullet Topic: PRINTER NOT FOUND after re-installing Windows
    Posted: 07 Aug 09 at 10:04AM

I have been using ReDirect Pro from VBA for about 18 months with no problem.  My motherboard and hard drive had to be replaced so my machine was rebuilt.  I reinstalled reDirect Pro (this time with 2.2.8 rather than 2.2.5), registered and set up a Batch printer for VBA.  On "Printers and faxes" the printer "BatchPDF–VBA" is present as well as "PDF reDirect Pro v2" - both "Ready." 

I am using the "Class to Control PDF reDirect Pro programmatically", Michel_K17, Version 2.1.1 and the associated VBA code "Print_reports."

All worked perfectly before the rebuild and now I get "PRINTER NOT FOUND” - Error(100)

Any ideas?
 
Steve
 
IP IP Logged
Michel_K17
Moderator Group
Moderator Group
Avatar
Forum Administrator

Joined: 25 Jan 03
Posts: 1663
Quote Michel_K17 Replybullet Posted: 07 Aug 09 at 8:56PM
Hi!

   Yes, I think I see the problem. Please upgrade the ActiveX component to the latest version as well (v2.2.6) which is available [here].

   That should get you going.

   Please post back if the error continues as the error you reported does sound like it could also be something else.

   Cheers!

Michel Korwin-Szymanowski
EXP Systems LLC
IP IP Logged
Michel_K17
Moderator Group
Moderator Group
Avatar
Forum Administrator

Joined: 25 Jan 03
Posts: 1663
Quote Michel_K17 Replybullet Posted: 07 Aug 09 at 8:58PM
One more thing: are you also getting the error when using the PDF reDirect Pro printer normally (ie not via the class)?

Michel Korwin-Szymanowski
EXP Systems LLC
IP IP Logged
steve
Newbie
Newbie
Avatar

Joined: 18 Mar 08
Location: United States
Posts: 5
Quote steve Replybullet Posted: 10 Aug 09 at 7:58AM

It does work printing stand-alone (without VBA) before I installed the ActiveX component.   I installed the ActiveX component and the VBA version is still giving the same error.  I checked the Program Files and the entries you show are indeed present.  Their Date Modified is 7/6/2008. 

IP IP Logged
steve
Newbie
Newbie
Avatar

Joined: 18 Mar 08
Location: United States
Posts: 5
Quote steve Replybullet Posted: 10 Aug 09 at 8:03AM
I really need this to work now.  (One becomes dependent upon good software)  Perhaps I should go back to version 2.2.5.  It did everything I need.
IP IP Logged
Michel_K17
Moderator Group
Moderator Group
Avatar
Forum Administrator

Joined: 25 Jan 03
Posts: 1663
Quote Michel_K17 Replybullet Posted: 10 Aug 09 at 10:21AM
Hi,

   Yes, certainly going back to what worked well is always a good strategy (at least that's what I found). I am surprised nonetheless as I not had any problems with the latest version.

   Do you also get the error when you run my sample VBA code in Word, Excel or Access?

   Anyway, if you decide not to go back to v2.2.5, the next steps would be to go into PDF reDirect Pro >> Preferences >> and turn ON the error log feature. Then, try your VBA code again to record the error, and then go back to the Preferences to recover the log. Copy-and-paste the log into an e-mail sent to exp (at) exp-systems (dot) com.

   If you go back to v2.2.5, and it works, please let me know too, just in case I've missed something.

   Best regards,

Michel Korwin-Szymanowski
EXP Systems LLC
IP IP Logged
steve
Newbie
Newbie
Avatar

Joined: 18 Mar 08
Location: United States
Posts: 5
Quote steve Replybullet Posted: 10 Aug 09 at 12:03PM

I found the problem.  I am embarrassed, but I guess there might be someone out there as careless as I am...so here goes.  When I originally set up the PDF printer, I named it “BatchPDF–VBA.”    When I rebuilt my machine and setup the PDF print again, I entered the name “BatchPDF-VBA” with the small hyphen “-“ instead of the large one, “–“.  That is why the print worked fine in Word and Excel, but not in my VBA code.  All is well now.  Thanks so much for your help, Michel. 

IP IP Logged
steve
Newbie
Newbie
Avatar

Joined: 18 Mar 08
Location: United States
Posts: 5
Quote steve Replybullet Posted: 23 Sep 09 at 7:41AM
Problem solved
IP IP Logged
Michel_K17
Moderator Group
Moderator Group
Avatar
Forum Administrator

Joined: 25 Jan 03
Posts: 1663
Quote Michel_K17 Replybullet Posted: 23 Sep 09 at 7:04PM
Cool! Smile

Thanks for  posting back.
Michel Korwin-Szymanowski
EXP Systems LLC
IP IP Logged
Post Reply Post New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum