Print Page | Close Window

Access Denied

Printed From: www.exp-systems.com
Category: PDF reDirect
Forum Name: Using PDF reDirect
Forum Discription: Questions and Comments on using PDF reDirect Freeware and Pro
URL: http://www.exp-systems.com/Forum_exp/forum_posts.asp?TID=210
Printed Date: 19 Aug 19 at 10:32PM


Topic: Access Denied
Posted By: uk144
Subject: Access Denied
Date Posted: 27 Apr 06 at 4:42AM
Not sure whether this is a PDF reDirect issue but here it is....

If I create (& Save)an MS word document on 1 PC on my LAN I can access it and from another PC on the LAN. If I make a PDF of that (using latest freeware version) I find that I cannot access it from the other PC on the LAN or Copy it over. I am saving it to the same folder each time. Is there anything I am missing in PDF reDirect that will affect permissions?

Thanks



Replies:
Posted By: Michel_K17
Date Posted: 27 Apr 06 at 9:46AM
Hi uk144,

   I cannot see any reason why this would be the case. The PDF files are written to the drives with no restrictions. Just to be clear on what you are doing:
  1. You create a PDF file
  2. You save it on a shared drive or folder
  3. You try to open the PDF from a different PC, and you get an error
   Is that correct?

   The only thing I can think of is that you need to make sure that the PDF Reader is not accessing the PDF from the 1st PC. So, if the file is opened in PC #1, you will get an error on PC #2 if you try to move it, you will get an error that says:

      "Cannot move PDF: It is being used by another person or program".

   You asked about permissions. You can check the following:
  • Start PDF reDirect by selecting "Print" from a program such as MS Word.
  • Press [CTRL]+[SHIFT]+[ESC]: this will bring up the Task Manager.
  • Click on the Processes tab, and look for two programs called "PDF_reDirect.exe" and "Capture.exe".
  • In the next column (called User Name), it should be your name that you used to logon. The permissions of that user is what PDF reDirect will be able to do in terms of Saving files. Let me know if it is not running under your name.
   I hope that helps...

Michel


Posted By: uk144
Date Posted: 28 Apr 06 at 10:42AM
Thanks for the reply.

You are right - the 3 points are exactly what I am doing. For clarity no other user has the file open when I am trying to access the file from another computer.

I have checked the permissions and all is ok (my user name is running against both processes).

Thanks for your input.


Posted By: Michel_K17
Date Posted: 29 Apr 06 at 1:17PM
Hi,

   I tried to duplicate the problem. I have here a Win 20003 server and a few PCs. I created a PDF using PDF reDirect and saved it to a mapped/shared network drive. Leaving PDF reDirect open, I went to two other PCs and I had no problem opening the PDF from the other PCs.

   Without being able to reproduce the problem, I am not sure how I will be able to help you. Here are a few questions that might help me out:
  1. What kind of LAN and Servers do you have?
  2. Which version of PDF Reader are you using?
  3. Can you, from the 2nd PC, make a copy of the PDF to the local drive, and then open it?


Michel


Posted By: uk144
Date Posted: 02 May 06 at 2:47PM
Thanks for you comments.

I am using a LAN with XP PRO PC's (both Dell dimensions) through a Netgear DG824M Router/modem.

I am using Acrobat 6.0 on the machine that is creating the PDF's and Croabt reader 7.0 on the one which I am trying to access the file through the network.

I cannot make a copy of the file on the from the 2nd PC ( I get the same 'access denied' arror). However if I save the PDF that I am creating on the first machine directly onto the local drive on the 2nd machine (choose this as the location in PDF re-direct) then all is well. I can access the file on the 2nd machine. Most confusing! The strange thing is that I do not have this problem with MS word docs - only PDF's i have created.


Posted By: Don Q
Date Posted: 13 May 06 at 10:09AM
Just in case you thought you were the only one in trouble... I have the exact same problem with 2 PC on my LAN under XP Pro (Dell Dimension & Asus MB own built). I am moving folders to a new PC. Some PDF files cannot be copied, access denied. I have not touched them in months.
When I initiate the move (copy) from the old PC (where the originals are located) to the new one it works! But when I access the same pdf file from the new PC (remote) no way.


Posted By: Michel_K17
Date Posted: 13 May 06 at 10:58AM
Hi DonQ,

   Thanks for letting me know. I'll keep an eye for this problem in case it ever happens to me. Hopefully it will because I setup 5 months ago a complete network here with 4 PC's and one Windows 2003 Server and I am creating a lot of PDF accross the network, saving directly to other PCs, or on shared drives.

   So far, I have not had any problems, but if I can duplicate the problem, this will help me find the cause, and the fix too. Unfortunately, it is impossible for me to fix something that does not happen to me.

   In your case, have you tried moving other files (not a PDF) initiated from the new PC? Do those work? Also, try to create a new PDF from the old PC, then. once it is saved, initiate a move from the new PC. Does that work? (ie does the problem still occur with new files?)

   Those are things that I would start looking at if I had the problem here.

   Cheers!

Michel.


Posted By: Don Q
Date Posted: 15 May 06 at 3:50AM
Hi Michel,

Yes, I can move any file other than PDF both ways without any trouble.
I first became aware of the problem when I copied a folder with a bunch of files of various types. The copy was aborted (with the error message mentioned above) after 3 minutes of transfer.
I cannot open that PDF file on the original PC from the new (remote) PC (access is denied) but I can open the copy on the new PC.
However, some PDF files got copied all right the first time and I can transfer them both ways and open from both PCs. I looks like only older PDF files (created with older version of Acrobat ?) are blocked. There is also a difference which should not matter but you-never-know : I run office 2003 on the new PC and office 2000 on the old one.
So I tried to create a new PDF file on the old PC.... and there it is ! Word simply hangs while converting to Acrobat 5 (that's all I have)! I had to abort. Even with the Distiller. So I sent an error report to MS and the reply came (more information button): Solution Found: upgrade your version of Microsoft Office !

So the problem cannot be duplicated. I suspect something gradually went wrong between Acrobat and MS (could it be since SP 2 ?). Why this should result in an "access denied" problem is something for a Dan Brown software hero from Digital Fortress.
Cheers,


Posted By: Michel_K17
Date Posted: 16 May 06 at 12:41AM
Hi,

   Thanks for the update. I really liked Microsoft's answer!

Michel.


Posted By: Don Q
Date Posted: 17 May 06 at 10:26AM
Michel,
I'm back with more fun: I copied another directory to the new PC and on one of the files I got "Could not open FILENAME" "Probable cause: file sharing or permission access".
This on a ZIP file. So I stopped AVG anti-virus, installed Winzip (same version), tried again. No good. Tried to open the zip file from within winzip (on the new PC) and got the same result.
The files opens nicely on the old PC.
Copied the file from old to new (initiating from the old PC) and everything goes.
Created a new zip file (Windows did not complain) and opened it from the new PC on the old. All OK.
I have no clue.
Cheers,
Don


Posted By: Michel_K17
Date Posted: 17 May 06 at 8:27PM
Hi,

   I don't know either. On my old PC, I had a file that I could not delete, read, or modify. It was just "stuck" there for three years. Sigh...

Michel


Posted By: pinkmast3ritza
Date Posted: 03 Nov 10 at 5:08PM
Hy. I runned into that damn problem too. And after days of searching I finally found this software: Long Path Tool.
It's GREAT. You can find it here: http://www.longpathtool.com/
Regards.



Print Page | Close Window