Print Page | Close Window

Error 1801 during installation

Printed From:
Category: PDF reDirect
Forum Name: Installation Errors
Forum Discription: Installation Errors and Workarounds
Printed Date: 24 Jun 24 at 4:27AM

Topic: Error 1801 during installation
Posted By: Michel_K17
Subject: Error 1801 during installation
Date Posted: 17 Aug 05 at 11:35PM
   Officially, Microsoft says that Error 1801 means "The printer name is invalid", but provides no other explanation. We have traced this problem to two possible reasons:

1. You have insufficient privileges
   You do not have write access to the print monitor part of the registry. In fact, one user who experienced this problem thought he had "administrator" privileges, but his IT department had restricted his account in such a way that writing to the "Monitors" section of the Printer Registry was restricted. This was resolved by fixing his privileges.

2. There is a conflict
   There may be a 3rd party port monitor that may have come with a printer currently installed, or which was installed in the past, but improperly removed. The following products are believed to cause the 1801 error:

- PrimoPDF
- HP 6122 printer driver
- HP Photosmart 230 printer
- Funk Software Proxy Host

   By removing the offending product, Some users were able to install PDF reDirect successfully. They were also able to re-install the offending product afterwards. However, in some instances, they found that the Port Monitor of the offending product remained even after removal, and they had to manually edit the registry to remove the Port Monitor entry.

WARNING! Editing the registry can cause your computer to fail. Proceed only at your own risk: EXP Systems LCC assumes no liability if you decide to edit your registry.

It is strongly recommended you make a backup of your registry before continuing any further.
Open the registry with RegEdit and navigate to:


Look for a registry key for the offending product. Delete the entry, and reboot. PDF reDirect should now install properly.

Re-install the offending product (if applicable)

Michel Korwin-Szymanowski
EXP Systems LLC

Posted By: davewhiteav8r
Date Posted: 30 Dec 05 at 10:57AM
Nope, none of the above is true on my computer.  I am the only user and have full privileges.  None of the above software is installed on my computer, and none of the applicable registry keys are in the regsitry.  I will continue to try to install this update after a reboot and let you know how it goes, but you don't have the answer yet.

Posted By: davewhiteav8r
Date Posted: 30 Dec 05 at 11:48AM

Well, tried uninstalling the old version of PDF Redirect Pro and then installing the new version.  Same result, installation dumps with an 1801 error code.  Then tried reinstalling the older version and doing the update after rebooting.  Same result.  However, I did notice that when your installation program cleans up after the failed installation, it removes the previously installed PDF Redirect printer from my printer folder, thus ruining the previously installed version.  Probably this is the reason the error log showed no earlier version--it was from a second attempt to install, and the previous aborted attempt had deleted the PDF Redirect printer.

Posted By: Michel_K17
Date Posted: 31 Dec 05 at 12:17PM
To everyone,

   Dave has helped me troubleshoot. We have made some progress in terms of finding a workaround which installed fine on his computer. I modified the installation of the printer slightly and it seemed to work on his computer. You can download the modified (v2.1.3) installation program [ - here ].

   This is the link for the "Pro" version. If you need the basic version, then install the Pro version, go in the preferences, and choose to switch to the Freeware version.

   I hope to have a more "permanent" fix soon.

Posted By: gadams
Date Posted: 05 Feb 06 at 2:02PM
I am getting the 1801--priviledges error.   I installed it on my win98 machine no problem, however, on win2000 and winxp I get this error. I have been fighting with this error for 3 weeks.

Could you please contact me ASAP to help resolve this.

Posted By: Michel_K17
Date Posted: 05 Feb 06 at 6:15PM

A couple more things that are worth looking at:

  • Log in as the Administrator. Although your account may be an "administrator" account, there may be a "per user" restriction against your user account which is preventing you from installing a printer, printer driver, port, or port monitor. What you can do is to login using the "real" administrator account as follows:
    • at the welcome screen, Press [CTRL]+[ALT]+[DEL] twice until the classical login window appears.
    • Type "Administrator" as the username.
    • Enter the Administrator's password.
    • Install PDF reDirect from this account
    • For Windows Vista and Win 7, see the instructions located [ - here ].

  • Check your registry permissions. Your account registry permissions (even though you are an administrator) may be preventing you from installing a printer. WARNING: Changing your registry settings can permanently cause your computer to stop working. Only proceed if you know what you are doing. We do not take responsibility for any damage that may be caused by following these instructions. Check your settings as follows:
    • Go to your "Start Menu" and select "Run"
    • Type "Regedit" and hit the [Enter] key
    • Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
    • Click the Edit >> Permissions menu
    • Make sure that your permissions give you "Full Control"

  • Check that the Windows Spooler Service is running. The Windows Print Spooler Service must be running to install/remove printers and port monitors. From the Start Menu >> Control Panel >> Administrative Tools >> Services >> Look for the service called "Print Spooler" and make sure it's started/running.
  • Make sure you have read/write access to the Windows Printer Spool folder. That folder is located here: C:\Windows\System32\spool .  You should have access to the sub-folder located within. You can test access by copying a file to that folder. You may get a UAC warning to give the Admin password. That would be OK as long as it works afterward.

Michel Korwin-Szymanowski
EXP Systems LLC

Print Page | Close Window