Print Page | Close Window

Application fails to lauch

Printed From:
Category: PDF reDirect
Forum Name: Installation Errors
Forum Discription: Installation Errors and Workarounds
Printed Date: 19 May 24 at 9:33PM

Topic: Application fails to lauch
Posted By: rcarrier
Subject: Application fails to lauch
Date Posted: 26 Dec 07 at 2:11PM
The PDF redirect application fails to start when double-clicked. When started, the PDF_Redirect procees shows up in the Task Manager and then disappears after a split second. This happens whether loading the free or pro versions. I have tried the process of uninstalling, removing the prefs from the user folder, restarting and reloading several times with no change in result. Help!

Posted By: Michel_K17
Date Posted: 26 Dec 07 at 11:34PM
Hi there,

    Is this something new (ie it's was working and suddenly stopped), or it never worked from day one?

    Also, it would be useful for me to know which version of Windows you are using (98, 2000, XP or Vista), and if you are running XP or Vista, can you let me know if you are running the 64 bit version (very rare). Also, do you remember which version of PDF reDirect do you have installed? The latest version is v2.2.5.

    Finally, here are things you can try to help me troubleshoot.
  1. First, use Windows Explorer to find the file called: "Prefs_v2.ini" located in the following folder: C:\Documents and Settings\MyUserName\Application Data\PDF reDirect
  2. Open the file and change the following line (~4th one down) from: -->Log=-1 to -->Log= 0
  3. Try running PDF reDirect manually again. It will fail to run, but hopefully, the error log will be created, and it may give a hint of what the problem might be.
  4. Now delete the "Prefs_v2.ini" file and try running PDF reDirect. A couple of people have found that the preferences file was corrupted, and deleting it fixed the problem for them.
  5. If the program is still now running after step 4 above, please send me the error files located in the folder: C:\Documents and Settings\Michel_K17\Application Data\PDF reDirect\Bug_Reports. You should find 1 to 3 files depending on when the error occured, namely:
    • log_UI.txt
    • log_CA.txt, and
    • log_AX.txt
Thanks. Hopefully this will help make some progress to get you up and running.

Michel Korwin-Szymanowski
EXP Systems LLC

Posted By: rcarrier
Date Posted: 27 Dec 07 at 4:14PM
Running XP 32 bit with version 2.2.5
Followed your instructions and no log file was created. Deleted the prefs file and application still did not start. No new prefs file was created at launch attempt.
Any other ideas?

Posted By: Michel_K17
Date Posted: 28 Dec 07 at 2:09AM

    I am sorry to hear that it is still not working.

    Does it work properly when you use the print command from a program such as Word or Excel?

    Let's try this next: Please delete the following folder:
C:\Documents and Settings\MyUserName\Application Data\PDF reDirect\Temp

Does it still fail to start?

    Has the program ever worked on this computer? Did you get any error messages during the installation?

    Finally, try starting the program called "Capture.exe"
manually (located in the PDF reDirect folder), then check the Task Manager: is it in your list of running programs? If yes, then select, and choose "End Process" to kill it. At least that would tell me that this program can run on your PC.


Michel Korwin-Szymanowski
EXP Systems LLC

Posted By: rcarrier
Date Posted: 03 Jan 08 at 1:33PM
I did work on this computer, but stopped with an upgrade.
Removing the temp folder has no effect.
Capture will run.
How about this, I can log in to the computer as a different user and it runs just fine. Does this put any user specific info in the registry?

Posted By: Michel_K17
Date Posted: 04 Jan 08 at 12:54AM

    Very little "per user" information is set in the registry by PDF reDirect. As I recall, there is the installation date (in an encrypted format) to track the 90 day evaluation of the Pro version. I can't think of anything else off the top of my head.

    Thanks for checking that Capture will run: this tells me that the problem truly resides with the user interface portion of the program (UI.exe). It is interesting that you noted that the program is running for a different user. Therefore, rather than the registry, I would take a second look at user folder. Please try deleting the entire user folder:

C:\Documents and Settings\MyUserName\Application Data\PDF reDirect

Did that fix the problem?

Looking for my notes from a different person who had a similar problem two years ago, we never did find a complete cure. We found that the older version worked for him, so he downgraded to that version. The reason why the error was occuring was never fully understood.

    Anyway, let me know of deleting the entire folder helped. If not, them I am not quite sure what to do next, but I'll think about it.

Michel Korwin-Szymanowski
EXP Systems LLC

Print Page | Close Window