Print Page | Close Window

Save button is greyed out

Printed From: www.exp-systems.com
Category: PDF reDirect
Forum Name: Using PDF reDirect
Forum Discription: Questions and Comments on using PDF reDirect Freeware and Pro
URL: http://www.exp-systems.com/Forum_exp/forum_posts.asp?TID=196
Printed Date: 13 Jun 24 at 9:27AM


Topic: Save button is greyed out
Posted By: farisee
Subject: Save button is greyed out
Date Posted: 06 Apr 06 at 8:58AM

When I try to print, no matter what I do the SAVE button is not available.  I upgraded to v.2.1.9 and still the same thing.  I turned on the log and here is what I see:

96,26586.77,"UI",3,"START LOGGING: 4/6/2006 7:23:06 AM"
96,26586.77,"UI",4,"User clicked on checkbox to start Logging"
96,26586.77,"UI",5,"Failed to Find Capture's Comm Channel"
96,26589.85,"UI",6,"Saving Preferences to file..."
96,26590.19,"UI",7,"   - Completed Writing to INI Preferences File"
96,26590.19,"UI",8,"Failed to Find Capture's Comm Channel"
96,26590.2,"UI",9,"***************************************"
96,26590.2,"UI",10,"   AN UNEXPECTED ERROR HAS OCCURED in SaveBatchSettings"
96,26590.2,"UI",11,"***************************************"
96,26590.2,"UI",12,"   - DLL Error Number =  0"
96,26590.2,"UI",13,"   - Error Number =  9 Error Text: Subscript out of range"
96,26592.76,"UI",14,"   - Disconnect FTP Folder"
96,26592.76,"UI",15,"   - Disconnect from SMTP Engine"
96,26592.77,"UI",16,"Cancel Button Pressed"
96,26592.77,"UI",17,"Failed to Find Capture's Comm Channel"
96,26592.77,"UI",18,"   - Cleanup Temp Folder"
96,26592.77,"UI",19,"Clean up Temp Files"
96,26592.77,"UI",20,"Saving Preferences to file..."
96,26593.15,"UI",21,"   - Completed Writing to INI Preferences File"
96,26593.25,"UI",22,"Program Completed. Shutting Down."
96,26593.25,"UI",23,"STOP LOGGING: 4/6/2006 7:23:13 AM"

...also when trying to print I see this in the log file...

96,27877.33,"CA",3,"START LOGGING: 4/6/2006 7:44:37 AM"
96,27877.33,"CA",4,"Windows Version: 2- 5.1.2600  Service Pack 2"
96,27877.33,"CA",5,"AppData Path: C:\Documents and Settings\xyz\Application Data\PDF reDirect\"
96,27877.33,"CA",6,"Resources Path: C:\Program Files\PDF reDirect\"
96,27877.33,"CA",7,"Temp Path: C:\Documents and Settings\xyz\Application Data\PDF reDirect\Temp\"
96,27877.35,"CA",8,"Thumbnails Path: C:\Documents and Settings\xyz\Application Data\PDF reDirect\Temp\Thumbnails\"
96,27877.35,"CA",9,"Get Command Line Data."
96,27877.35,"CA",10,"   - Loading the Batch ini data for PDF reDirect v2"
96,27877.35,"CA",11,"An expected Error Occured in LoadBatchSettings"
96,27877.35,"CA",12,"   - DLL Error Number =  0"
96,27877.35,"CA",13,"   - Error Number =  53 Error Text: File not found"
96,27877.35,"CA",14,"-> Document Name is: login_user_asp?FID=0"
96,27877.35,"CA",15,"-> UserName is: xyz"
96,27877.35,"CA",16,"-> UniqueID is: 1715252443"
96,27877.35,"CA",17,"-> Who started me is =  1"
96,27877.35,"CA",18,"Load Library C:\Program Files\PDF reDirect\bin\gsdll32.dll..."
96,27877.38,"CA",19,"...Success."

It looks like I'm missing an ini file???

 

 




Replies:
Posted By: Michel_K17
Date Posted: 06 Apr 06 at 1:02PM
Hello,

   Sorry to hear about the difficulty. First, I'll start with the error message that says :"AN UNEXPECTED ERROR HAS OCCURED in SaveBatchSettings". This error is normal if you do not have any batch PDF printers installed (a feature that is part of PDF reDirect Pro only). This does not affect the functionality of PDF reDirect.

   Let me describe what should normally occur: you select "Print" in the application such as MS Word, select the "PDF reDirect" printer, then PDF reDirect user interface (window) appears, and the printer output appears as an entry in the Merge List called "Printer Output...", and the Save button is not greyed out.

   The problem you are reporting can occur in one of three ways (at least from what other users have reported):
  1. First, for a few users, PDF reDirect will refuse to work correctly right after installation. The first attempt fails (printer output does not appear in the merge list), but then, it works on the second and subsequent attempt. Clearly, this is not your case.
  2. Second, PDF reDirect refuses to work correctly until the computer is rebooted. Apparently, the Windows Print Spooler sometimes refuses to recognize the new printer until it is re-started. You can reset the Print Spooler reset either by rebooting, or by manually shutting down and restarting the service. This may be the case for you: have you tried rebooting?
  3. Third, PDF reDirect will not work if the user's Windows account contains unicode characters. Unicode characters are used for complex languages such as Cyrillic, Chinese, Korean, Japanese, etc. In those instances, there are a couple of options. First is to change the user name to something that does not use unicode characters. Second is to activate the unicode compatibility mode in Windows 2000/XP (Start Menu >> Settings >> Control Panel >> Regional and Language Options >> Advanced).


   Please take a look and let me know if any of these conditions apply to your situation.

   Regards,

Michel


Posted By: tomj1969
Date Posted: 06 Apr 06 at 3:02PM
I am having the same problem and none of the suggested solutions work. I have restarted my computer multiple times to no avail.

I have tried printing from several programs, including Firefox, Word, Excel, Internet Explorer, Notepad, and even the "print test page" function in the printer settings. I have also tried opening PDF Redirect before printing.

The PDF Merge feature DOES work for me - I am just unable to convert other files into PDF docs.

My computer is running a P4 2.4ghz with 1gb ram, so it should not be a system problem. I've also been able to use CutePDF in the past without a problem, but would like to switch to PDF Redirect because of the merge feature.

Any suggestions of other things I could try to get this working would be appreciated. The only thing I have not done yet is to reinstall the program. I'll try that and if it works post back on the forum, but I am not optimistic...


Posted By: farisee
Date Posted: 06 Apr 06 at 3:23PM
So far I've stopped and started the print spooler, but still no save button.  It has worked previously.   I will let you know if rebooting works when I get a chance.


Posted By: tomj1969
Date Posted: 06 Apr 06 at 3:27PM
OK, I think I figured it out.

I uninstalled PDF Redirect, restarted my computer, reinstalled it and restarted my computer again. Save button was still greyed out.

I had been using Foxit PDF reader as my default reader for PDF files, so I guessed it might be a compatibility issue between that program and PDF Redirect. I changed my default program for pdf files to Acrobat Reader and was then able to print to PDF Redirect.

While I am pretty sure the problem was caused by using Foxit as my default PDF reader, I am not sure if it would have happened if I did not have both Foxit and Acrobat Reader installed. I am guessing it still would have. One of the nice things about Foxit is that it does not do much to Windows Registry and doesn't have a boatload of plugins that launch every time you use it. Maybe PDF Redirect relies on those registry entries or plug ins to work correctly?

Farisee, if you are using a PDF reader other than Acrobat, you might want to try changing it. I am assuming since you were able to paste the error log in your message, you probably know how to change file associations. On the off chance you don't, here is how to do it:

1. Open Windows Explorer
2. Select "folder options" from the "Tools" drop-down menu
3. Select the "file types" tab
4. Select the "pdf" extension in the "extensions" column
5. Click the "Change" button
6. Choose "Acrobat Reader". If you have it installed, it should appear as a recommended program.
7. Click "OK".
8. Click "OK" again

Hopefully that will fix the problem for you if none of the other recommended steps did.


Posted By: PapiBourgenot
Date Posted: 06 Apr 06 at 3:37PM
Hi there,

   Very weird. I use FoxIt here as well (and I have PDF Reader v4.0.5, v5.0.5 and v7.0.7) and I also have Acrobat installed, yet I have not had the problem you are reporting. Indeed, PDF reDirect does not rely on any of those during the cration of the PDF. For example. I have a test system which only has PDF reDirect installed (no Reader whatsover), and it still works fine.

   Let's talk about FoxIt for a second: PDF reDirect does use the FoxIt viewing engine to create the preview (the little picture in the lower LH side of the window). I am wondering if the newer version of the FoxIt Reader is perhaps the culprit, so I will look into that (my version is 6 months old).

   Finally, PDF reDirect uses the default PDF association to open the PDF in the reader, so your instructions are indeed the right away of changing the default viewer for PDF reDirect.

   Thanks!

Michel


Posted By: tomj1969
Date Posted: 06 Apr 06 at 3:43PM
It could be related to the new version of Foxit - I have version 1.3, build 0104. I am just happy that I have redirect working - I have been able to print to PDF from several applications since I changed my file association.


Posted By: farisee
Date Posted: 07 Apr 06 at 2:17PM

Okay, its working again.

I don't have foxit so that wasn't the problem.

When I rebooted I noticed that an End Task popped up on Adobe.  My guess is that there was something hung on Adobe Reader causing my issue.  If it happens again I will kill the process and let you know if that fixes it.

 




Print Page | Close Window