Print Page | Close Window

Can’t get PDF file on Win2K Server.

Printed From:
Category: PDF reDirect
Forum Name: Citrix & Windows Terminal Server (Beta)
Forum Discription: Questions and Answers for Server Environments
Printed Date: 17 Apr 24 at 11:25PM

Topic: Can’t get PDF file on Win2K Server.
Posted By: Simon581923
Subject: Can’t get PDF file on Win2K Server.
Date Posted: 27 Jul 05 at 12:09PM


  I've been tried to get PDF file by PDF reDirect Pro 2.0.15 and failed for several times. It was the first installation. By the way, I found that I could not install v2.0.15 by Terminal Service Client, I had to install it on the Server and it is almost 100 KM away from me.

  Today is not my lucky day. After installed it, I found that I couldn't make PDF file even from a 4 bytes text file. The red bar stoped near 24%. I've tried several times and the result was the same.

  What's happened?

  I've installed PDF995, Acrobat on the same box. Would you please give me an answer?

  Yes, I also installed the dedicated capture.exe from you.

  Anyway, your solution is available on my XP machine.

Posted By: Michel_K17
Date Posted: 27 Jul 05 at 1:09PM

   Windows Terminal Services is not supported in v2.0, but will be supported in v2.1.

   If you need it now, you can install the latest PDF reDirect Pro v2.1 "beta" (v2.0.900) which is compatible with Windows Terminal Services. You may still need access to the server for installation (I have not tested remote installation yet), but otherwise, that version seems to work fine on Windows 2003 Server (not yet tested in Windows 2000 Server, but it should work there too).

   You can find out more about the beta version and where to download it [ - HERE ].

   Please let me know if you have any questions about Windows Terminal Services, or if you experience any problems. If you are interested to join our "Beta Test Team", let me know and I will add you to the mailing list.

Posted By: Simon581923
Date Posted: 27 Jul 05 at 8:15PM


I'm interesting to join your "Beta Test Team", because I'm looking for a PDF output solution for my job.

I'll try to install v2.0.900 and test it as soon as posible. I will post the result tonight (Taipei time).

Posted By: Simon581923
Date Posted: 28 Jul 05 at 9:21AM


  At first, the server is Windows 2000 Server SP4.

  I tried to install v2.0.900 via the Terminal Service Client, but it failed again. However, it was not important. I asked someone to install it on site.

  I've tried to make PDF file by v2.0.900, the red bat went 50% and then the error message shown. I will mail two log files to you later.

  The difference between these two log files were one made by GNU Ghostscript and the other on by Distiller. The situation is the same, about 50% red bar and an error message shown.

  Would you please to help me to solve the problem?


Posted By: Michel_K17
Date Posted: 28 Jul 05 at 6:45PM
Hi Simon,

   Thanks for the logs. I have looked at them. I think the problem is that you are trying to save to a path or with a filename that contains chinese characters.

   There is an outstanding bug which I hope to fix soon which will cause the PDF not to be created properly if the file path or file name contains "complex characters". Could you try again with english characters only to see if that works? If it does, then that will confirm my suspicion.


Posted By: Simon581923
Date Posted: 29 Jul 05 at 12:41AM

I am having a business trip today. I'll test it when I back to my office. It should be next Monday. I'll post again and let you know the result.

Thank you for your help.

Posted By: Simon581923
Date Posted: 31 Jul 05 at 7:54PM


1. After removing any Chinese characters in the file and directory name, v2.0.900 could make PDF file normally.

2. More question:

  I'm using Oracle 9iAS R1, the system got some limitation on the printer name: NO BLANK ALLOW in the printer name. Therefore, I could not use the batch printer function with Oracle 9iAS R1. Any idea?

Posted By: Michel_K17
Date Posted: 31 Jul 05 at 9:33PM
Hello Simon.

   I am surprised that Oracle would not allow blanks in the printer name. The problem is that the batch printer name must contain the words "Batch PDF" as the first part of the printer name in order to work as the batch printer.

   Is this something Oracle is going to fix? There are plenty of printer names that have spaces in them. Does the problem only occur when trying to use a script?



Posted By: Simon581923
Date Posted: 01 Aug 05 at 9:01AM

Well, me too! I was surprised when I found what the problem was.

No, I don't think Oracle will fix this problem. Oracle did never think that is a bug, it was just a system limitation.

I thought that the solution is we could change the batch printer's name to what we want. Is it possible?


Posted By: Michel_K17
Date Posted: 01 Aug 05 at 10:51PM
Hi Simon,

   Yes. I will change the name of the batch printer in the next Beta release, and remove all spaces. I have added that to my "To do" list.



Posted By: Simon581923
Date Posted: 01 Aug 05 at 10:55PM

Hi Michel.

  What I want are focued on the Batch PDF function:

1. User defined batch PDF printer name.

2. Using Distiller to be the conversion engine.

3. Overwrite the existed file with the same file name.

4. Available on Win2K Server SP4.

Any suggestion, please let me know. You can contact with me by mail. 

Posted By: Simon581923
Date Posted: 01 Aug 05 at 11:06PM

Hi, Michel.

If you could removed all spaces, it is available for my 1st condition. Would you please tell me the other 3 conditions are available?

And, when will you release the next Beta?

Posted By: Simon581923
Date Posted: 11 Aug 05 at 4:16AM

Hi Michel,

I have found a solution to use the batch PDF printer with blank, which Oracle had agreed that was a bug.

For example, the virtual printer name is Batch PDF - TEST. I rewrote the code to be

v_PRINTER_NAME := '''' || 'Batch PDF - TEST' || '''';

Then everything worked.

I'm using v2.0.15 with the dedicated CAPTURE.EXE on the server. However, there are almost 400 reports. I have just modified some reports for urgent case. And, I'm still waiting for the next Beta.

Posted By: Michel_K17
Date Posted: 11 Aug 05 at 11:41PM
Hello Simon,

   Thanks for the update. I have found a way that you can specify any name you want for the batch printer, and I am implementing it this weekend, as well as finalizing some User Interface elements.

   The other batch features you requested will be worked next. Although I hate to commit to a date, I would suspect that the next beta will be available on or about August 29th. I will try to do better, but it will be very dependent on how well my testing goes with the addition of the many other features, particularly the new (faster, better) thumbnail display engine.


Posted By: Simon581923
Date Posted: 22 Aug 05 at 9:03PM


After more and more testing, I understood that the problem was caused by the terminal service.

There were no system problem with PDF reDirect v2.0.15 on Win2K Server when I did my jobs on the server locally.

Thank you for your great support.

Print Page | Close Window